Return to KLUBNL.PL main page

rsgb_lf_group
[Top] [All Lists]

Re: LF: SlowJT9 update (v0.9.10)

To: "[email protected]" <[email protected]>
Subject: Re: LF: SlowJT9 update (v0.9.10)
From: Andy Talbot <[email protected]>
Date: Tue, 20 Nov 2018 17:20:52 +0000
Dkim-signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=gmail.com; s=20161025; h=mime-version:references:in-reply-to:from:date:message-id:subject:to; bh=KRebuFp4y2GHE7vIJ64h6JOJQjdFo6J32OWMQbLw1IQ=; b=keg5rZZTyugy8mqr59jEJaRHZbs+l9Ilh/kZUTu0Oj/qMaXPEixq02LL0Czyc4tDbp wy45UJCct2utXBZpLyanW8udxj4HRQ1S4TOaX1AkvVCWFaJqHpLKeVuZPETby4jA8pUw rEQ5Ch4B1vFuHe0ibWm7QnI+cYTa3Ya8iDBlmbH7ZtmGPexzrHmGwe17f1U5YEt3ZnYw H3X+uzuvBBp1kejV+UQCKIJLf7O/bmxOFlajilOy3sckCq4bEDlarY2XGcf57XadrlpX AU0Y2lLeRG8FcllbmD2ZFqwQJqLgblyE9owtxDDTa/OmM4ETcjReOowM3Hw9vPzX+t5I jFEQ==
In-reply-to: <[email protected]om>
References: <[email protected]> <[email protected]> <[email protected]> <[email protected]om> <[email protected]> <[email protected]om> <[email protected]om> <[email protected]> <[email protected]om>
Reply-to: [email protected]
Sender: [email protected]
I'm having a bit more success now.   But there are still problems with soundcard interfacing.   I'm using the internal soundcard in the FDM-DUO and it now seems to have started working in that I can, most  of the time generate audio via that using the tune button.  It also works when sending messages.   Much of teh time

However, if I try to change the soundcard to the PC's internal one, sometimes it crashes out of the programme with an error message, sometems accepts it.   If it accepts it sometimes I get a tone out using the tune button, sometimes not.     Changing back to the FDM-DUOs S/Card often does work, but sometimes causes a crash and error message.

When a soundcard change is accepted, I find to get it to work I often have to exit the programme then start it again.




On Tue, 20 Nov 2018 at 16:54, Andy Talbot <[email protected]> wrote:
I'm getting confused as to where we are now ...

My messages are not generating any audio either, as well as the tune not doing so.  EXCEPT. just once only, the tune DID generate a tone.   
But then I couldn't get it to work again
I will keep playing

Still on  ver 0.9.10

Andy


On Tue, 20 Nov 2018 at 15:13, Rik Strobbe <[email protected]> wrote:

​Hello Andy, all,


I just tested and the baudrate change somehow effected the tuning, it is not working properly.

But message transmissions are working fine, so apart from tuning this version can be used.

I will have a look at it.


73, Rik  ON7YD - OR7T



Van: [email protected] <[email protected]> namens Andy Talbot <[email protected]>
Verzonden: dinsdag 20 november 2018 15:58
Aan: [email protected]
CC: rsgb_lf_group
Onderwerp: Re: LF: SlowJT9 update (v0.9.10)
 
There is also another problem which 'could' be connected to the no audio, somehow.

I unplugged the USB soundcard, then relaunched SlowJT9.   It had previously been directed to the now unplugged USB S/Card but instead of working out what to do and changing to the default (internal) S/C, it threw up an access violation message and I had to quit.    This happened each time I tried to launch.  The only solution was to plug the USB card back in, launch the programme and change the output soundcard to the internal one.



On Tue, 20 Nov 2018 at 14:47, Andy Talbot <[email protected]> wrote:
Nope, Rik.  I had thought  of that and it's set to maximum

Just tested on my Desktop, and exactly the same problem.  No audio from the default speakers.   So that's two PCs of different makes . Win versions with teh same problem

I also tried an external USB soundcard and directed the audio out to that.  Also so sound (RH slider to max) 

I am getting some irregular clicks occasionally, on the USB soundcard, and that also happened on the laptop once or twice




On Tue, 20 Nov 2018 at 14:34, Rik Strobbe <[email protected]> wrote:

Hello Andy,


the "power level" slider (at the right) is initially set to zero. Maybe that is the reason for no audio.

I agree that this is confusing, but I have done this for safety reasons (I don't want have any transmitter "blown" because of a too high audio level).


73, Rik  ON7YD



Van: [email protected] <[email protected]> namens Andy Talbot <[email protected]>
Verzonden: dinsdag 20 november 2018 15:24
Aan: [email protected]
CC: rsgb_lf_group
Onderwerp: Re: LF: SlowJT9 update (v0.9.10)
 
Rik 

I just tried installing this 0.9.10 version  on my Dell Inspiron laptop Win-10.  I set the soundcard correctly to  "Speakers / Headphones" and Tx tone to 1200Hz ,  hit enable Tx then  the 'Tune' button.   It shows as transmitting but there's no audio tone.     WSJT-X and other datacomms packages are working fine, both before and after trying

Normally don't get any issues like this with the default (the only) soundcard present.

I'll test on my other two PCs,  an HP Desktop with Win 7 and HP Notebook

On a different matter, I'll be writing this up in the next RadCom "Data" column (February's)   Could you summarise the baud rates and frequency shifts finally settled.   There has been so much discussion and changes I lost track and haven't followed the latest version
 


On Tue, 20 Nov 2018 at 13:50, Rik Strobbe <[email protected]> wrote:

Dear all,


I just uploaded a now beta-release of SlowJT9 (v0.9.10).

The changes are


JT9-2 and JT9-5 parameters changed to the original ones. The slightly slower baudrates make better advance of the transmission cycle. In theory this should improve S/N by 0.46 dB for JT9-2 and 0.74 dB for JT9-5.

Be aware that due to the baudrate changes there is NO BACKWARD COMPATIBILITY for JT9-2 and JT9-5. 
In other words: JT9-2 and JT9-5 send with v0.9.10 cannot be decoded with prior versions (v0.9.00 - v0.9.03) and vice versa.

The JT9-1 mode however is still the same and can be sent / received with all versions (and is WSJT-X compatible).


- JT9-10 mode (10 minute cycle) added, for the fearless.


I briefly tested v0.9.10 for in JT9-2 mode and it seems to decode (at least) at the same level as for the previous versions. But to determine a difference of 0.4dB, more extensive tests are needed.

The sole purpose of this version is to determine how JT9-2, and eventually JT9-5, behave in relation to the previous versions, so we can decide wether SlowJT9 will proceed with the original parameters (anno 2013) that imply an odd baudrate ratio between the JT9 submodes or my previous parameters, with "round number" ratios. 

Therefore all test reports, remarks, suggestions and opinions are most welcome.

For the same reason no other changes are applied.


Whoever is interested can download the SlowJT9 installation file at http://472khz.org/SlowJT9/SlowJT9_setup.exe.


For now only a Windows version of SlowJT9 is available. But as the used IDE has cross platform facilities it should be possible to support other operating systems as well in the future.


73, Rik  ON7YD - OR7T






<Prev in Thread] Current Thread [Next in Thread>